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The teaching, learning, communication, and practice of Developmental Biology require interested parties to be at ease with the6

considerable spatial complexity of the embryo, and with its evolution over time as it undergoes morphogenesis. In practice, the7

four dimensionality of embryonic development (space and time) calls upon strong visual-spatial literacy and mental manipulation8

skills, generally expected to be innate or to come through experience. Yet it has been argued that Developmental Biology suffers9

the most from available traditional media of communication and representation. To date, few resources exist to engage with the10

embryo in its 3D and 4D aspects, to communicate such aspects in one’s work, and to facilitate their exploration in the absence of live11

observations. I here provide a collection of readily-usable volumetric models for all tissues and stages of mouse peri-implantation12

development as extracted from the eMouse Atlas Project (E5.0 to E9.0), as well as custom-made models of all pre-implantation stages13

(E0 to E4.0). These models have been converted to a commonly used 3D format (.stl), and are provided in ready-made files for digital14

exploration and illustration. Further provided is a step-by-step walkthrough on how to practically use these models for exploration15

and illustration using the free and open source 3D creation suite Blender. I finally outline possible further uses of these very models16

in outreach initiatives of varying levels, virtual and augmented reality applications, and 3D printing.17
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Spatial thinking in Developmental Biology: understanding and communicating four dimensions.20

21

During mouse embryonic development a single, symmetric, undifferentiated cell transforms into a multicellular, differentiated22

organism populated by multiple specialised cell types (Pijuan-Sala et al., 2019). As new cells emerge, they migrate across the23

embryo, they squeeze between other tissues, they break down and deposit basement membranes, they traverse and integrate24

surrounding tissue layers (cfr. e.g. Arnold & Robertson (2009); Hashimoto & Nakatsuji (1989); Nahaboo & Migeotte (2018);25

Saykali et al. (2019); Viotti et al. (2014)). The embryo as a whole undergoes dramatic shape changes (McDole et al., 2018;26

Rivera-Pérez & Hadjantonakis, 2014; Snow, 1977). Students and researchers in mouse Developmental Biology are required to27

be familiar with such fundamental processes (gastrulation, cell migration out of the primitive streak, formation of the node,28

endoderm pocketing, gut morphogenesis, notochord deposition...). Yet, this requires them to build complex mental pictures29

involving simultaneous changes in multiple embryonic tissues, movement of different cell populations in three dimensions,30

and to entertain such complex mental representations as they evolve over time. Building such pictures is neither immediate nor31

intuitive, and for the many that do not have direct access to mouse embryos it usually only comes from the prolonged exposure32

to literature and the uncertain piecing together of a heterogeneous range of visual data formats. Here are then students and33

early career researchers scouring the literature for good representations of their structure of interest, at the right developmental34

timepoint, seen from that specific angle they need, with or without such and such other tissue. The outcome is rarely a single35

picture, and is typically a collage of disparate histological sections, immunostainings, electron microscopy images, diagrams.36

37

Crucially to this point, the mental manipulation of 3D objects, over time (i.e. 4D), actively calls upon cognitive skills38

whose teaching has long been the focus of psychological and education research; notions of representational competence,39

spatial visualisation, spatial perception, visual-spatial literacy (see e.g. Milner-Bolotin & Nashon (2011); NRC (2012)). The40

importance of "the skill for thinking in three dimensions", "for visualising shapes in the mind’s eye, rotating, translating, and41

shearing them", and "imaging complex changes over time in the form of a cinematographic visual image” (Chadwick, 1978)42

will resonate strongly with most developmental biologists, just as that of so-called "penetrative thinking", i.e. the capability to43

infer the cross-section of a layered object from surface features alone (Kali & Nir, 1996). While little research has focused on44

the importance of such skills in Developmental Biology Education (but see references in Hardin (2008)), foundational studies45

have been done in geoscience (and indeed compare the cross-section of a gastrulating embryo with the multi-layered landscape46

of earth crust sections). These studies have crucially shown that spatial thinking abilities can be i) taught, and ii) improved47

by practice (Kali & Nir, 1996; Titus & Horsman, 2009). Whether this transcends geological sciences or not, tools to foster48

visual-spatial literacy in Developmental Biology still remain scarce and not widely available (Hardin, 2008). It could be argued49

that the highly dynamic and dimensional nature of Embryology makes this discipline particularly penalised by traditional50

media of scientific dissemination.51

52

Vianello | bioRχiv | November 23, 2020 | 1–19

.CC-BY 4.0 International licenseavailable under a
(which was not certified by peer review) is the author/funder, who has granted bioRxiv a license to display the preprint in perpetuity. It is made 

The copyright holder for this preprintthis version posted November 24, 2020. ; https://doi.org/10.1101/2020.11.23.393991doi: bioRxiv preprint 

https://doi.org/10.1101/2020.11.23.393991
http://creativecommons.org/licenses/by/4.0/


When dealing with developmental data and with the inherent flatness (and stillness) of the printed page, the problem is not53

just the the extraction of information out of it (i.e. "understanding"), but also its deposition (i.e. "communicating"). Note the54

insidiousness of the problem: that is, even where one did successfully manage to mentally reconstruct complex representations55

of the system they want to illustrate, then its translation on paper still requires considerable artistic and technical ability.56

Regardless of the success of such translation process, it is this output that will serve as the basis for other scientists to57

inform their own mental pictures (cfr. Figure 1). The circle is vicious, and difficult to escape. A good illustration requires58

understanding, and a good understanding requires good summary references. If one does not have the possibility to see and59

explore real mouse embryos, dependence is built. Dependence on either luck and the pre-existence of illustrations of the60

embryonic context one wanted to illustrate, dependence on the pre-existing/solicited/paid work of rare scientists-artists, or61

dependence on the difficult investment of time and resources by the scientists themselves as to reach full illustrative autonomy.62

63

Fig. 1. The vicious cycle of scientific illustration. Blue does not have access to real mouse embryos, and thus their entire understanding depends on the mental
reconstruction of pre-existing representations from the literature. Blue’s output representations, regardless of the fidelity with which they match Blue’s mental reconstructions,
will in turn serve as the basis of understanding for other scientist (e.g. Pink, and Blue themselves). Blue is thus entirely dependent on the output of direct observers such as
Green, and has to wait for Green to draw the specific scenario needed.

How then to facilitate and democratise both the visualisation and the illustrations of mouse embryos? An important resource64

has been, and still remains, the Edinburgh Mouse Atlas Project (EMAP), the freely-accessible, annotated, online collection65

of 3D volumetric data hosted at https://www.emouseatlas.org/emap/ema/home.php, covering mouse development from66

pre-implantation, to gastrulation, to organogenesis and late post-implantation (Armit et al., 2017; Richardson et al., 2013).67

3D models are easily navigable and allow users to define cutting planes as to see virtual histological sections at any desired68

angle. The value of such resource is maybe understated, but here are on-demand, user-explorable, customisable, 3D (+69

timepoints) visualisations of mouse embryos at almost all stages of development. Clearly, this is a complete subversion of the70

normal illustration-spectator dependant relationship built by traditional developmental visualisation, and a powerful enabler of71

understanding (cfr. Figure 2) . Crucial in this, is the role played by the actual data-format (i.e. a 3D object in space) and how it72

allows to completely evade the two-dimensional constraints of the printed page. Put very simply, an interactive, explorable 3D73

model condenses the informational potential of as many 2D pictures as there are angles to visualise that model.74

75

With the evolution of our formats of scholarly communication, published data is also slowly starting to take life out of the76

page. Concomitant with the increasing use of experimental strategies outputting volumetric microscopy data, and with their77

application to the mouse embryo, such data is increasingly being presented as videos accompanying the online version of78

manuscripts. In these videos, the models are usually animated to rotate around their main axes, they might toggle specific79

structures on and off to reveal internal structure, or show internal cross-sections. Here is the dimensionality, here is the change80

over time, features so intimately associated with developmental biology (Hardin, 2008). The models live and are communicated81

in their 3D environment, if they are not user-explorable they are - at least - explored (cfr. Figure 2) . Even if just provided82

in their printed version, 3D models still remain potent embryonic representations. One could say that the understanding of83

e.g. tailbud structure, embryonic heart development, and uterine architecture is almost immediate when shown, respectively,84

as in (Arora et al., 2016; Dias et al., 2020; Ivanovitch et al., 2017), even without the animated videos that may accompany85

such publications. Still, access to these models and thus the ability to explore them, is entirely dependent on the sharing86

practices of each individual set of authors, or of the venue of publication. Even in the case of the EMAP database, where87

volume data for every single embryonic structure is indeed downloadable (most updated version of the collection available at88

https://datashare.is.ed.ac.uk/handle/10283/2805), this does not come in a format of easy transfer to common visualisation and89
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Fig. 2. The power of 3D models. Direct observers like Green do not just illustrate the object from a specific point of view, but also decide to provide a 3D model of the
original object (here, a boat). Blue can now observe the object from the specific angle they needed (becomes Green by proxy): the cycle of dependence is bypassed. Notice
however that Blue cannot necessarily use the model provided by Green (e.g. only available as a video, or as 2.5D) when communicating with Pink. The cycle of dependence
is broken at the understanding/reconstruction step, but not at the communication step.

illustration softwares. These conversion steps, and the digital reuse of 3D objects, requires skills that - while not difficult - are90

yet not mainstream compared e.g. to the relative familiarity one is nowadays expected to have for 2D illustration software.91

92

In the light of the "illustration -> understanding -> new illustration" framework outlined above , we finally also have to reflect93

on the usability of our visualisations. That is, to what extent do they allow the reader to transition from passive "visualiser" and94

"learner", to active user, "illustrator", "teacher", "communicator"? To what extent do they empower them? To what extent to95

they break this cycle of dependency? Is it possible to imagine a framework where illustrations not only catalyse understanding,96

but they simultaneously facilitate creative experimentation? Where the lifecycle of an illustration/model does not end upon97

publication but gets new life in the hands of the reader? There is an untapped value in 3D models, probably uniquely so for the98

mouse developmental biology community given the existence of repositories such as EMAP. Tapping into it only requires easy99

access to the models themselves and the technical know-how on how to use and explore such models digitally. And here are100

scientist that will be able to explore these models on their own. Scientists and students that will be able to incorporate them101

into their own illustrations. Outreach officers that will be able to deploy them in e.g. virtual or augmented reality applications.102

3D printers that will be able to bring these structure to the hands of students and of the public (Figure 3).103

104

Fig. 3. Visualisations become data. Green not only provides models, but makes them accessible too (e.g. copies of the model can be downloaded and manipulated).
Blue can actively explore the object and is even more likely to find the point of view they needed. Pink developed the technical skills to use the model itself, and can now
transform/reinterpret it, 3D print it, or use it in new visualisations. All of these elements feed back into the visual data formats available to the community, and thus further
catalyse understanding.
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I here provide a collection of readily-usable volumetric models for all tissues and stages of mouse peri-implantation develop-105

ment as extracted from the eMouse Atlas Project (E5.0 to E9.0), as well as custom-made models of all pre-implantation stages106

(E0 to E4.0). These models have been converted to a commonly used 3D format (.stl), and are provided in ready-made files for107

digital exploration and illustration. I further provide a step-by-step walkthrough on how to practically use these models using108

the free and open source 3D creation suite Blender. I finally outline possible further uses of these very models in outreach109

initiatives of varying levels, virtual and augmented reality applications, and 3D printing. I hope these resources and instruc-110

tions may add to those already available to the mouse developmental biology community, serve as a soft introduction to more111

members of our community to the world of 3D illustration, and encourage creative exploration and experimentation in such a112

visually rich and stimulating field that is that of embryology.113

A collection of volumetric models of embryonic stages.114

115

An overview of all 16 models available for download is provided in Figure 4. These models cover Theiler Stage (TS) 01116

to TS14, and include 8 custom-made models (covering TS01 to TS06, or E0.5 to E4.5), as well as 8 models assembled117

from EMAP data (covering TS07 to TS14, or E5.0 to E9.0). Also provided are two additional models corresponding to118

cross-sectional views of the early and late blastocyst models (TS04 and TS05, or E3.0 and E4.0), as to reveal the inner cell119

mass. As each of the 18 embryonic models provided is given as an assembly of individual subcomponents, a total of 251120

individual volumes are thus available for download, exploration, and reuse (see Supplementary Data Table for a complete list).121

122

The models have been deposited at http://doi.org/10.5281/zenodo.4284380 and will be found as 18 separate .blend files (one123

for each of the 16 stages, +2 open blastocysts). These files are to be opened with the free and open source 3D creation suite124

Blender (https://www.blender.org/) and have been prepared as to be immediately usable for exploration and illustration (see125

later paragraphs). Also provided are the 251 separate volumes of each embryonic structure represented, grouped by embryonic126

stage. These are provided as .stl format, as to be readily used not only for illustration, but also in 3D printing, gaming, and127

virtual/augmented reality environments. Finally, an additional .blend file with the full embryonic collection is also provided (as128

shown in Figure 4), as well as a "starting-pack" of pre-made materials to apply to the models (see Figure 5, and Glossary).129
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Fig. 4. Summary of the 18 assembled models available for download. for a total of 251 individual volume models. Models for early and late blastocysts are also given in
an open version showing the inner cell mass (not shown here).
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Fig. 5. List of pre-made materials available for download. By default, 3D models will be displayed as grayish-white, but the visual appearance of a model can be controlled
by applying materials/shaders to it. To facilitate the process, the above materials can be downloaded and used. These correspond to all the main colours, in a neutral and in
a glossy ("wet") version. "Special" materials include one made to mimic the surface of an epithelium, one showing mesenchymal cells migrating above it, and one making the
structure transparent. Technical details on how these materials were created are provided in the Methods section.
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Use of the models for exploration/understanding.130

131

As mentioned in the introduction, one of the biggest advantages of having access to 3D models is that they allow the user to132

take control over the exploration of these very models (as per the paradigm illustrated in Figure 3). A big part of the models133

provided here have been long accessible and explorable on the EMAP portal, but they come in a dedicated file format to be134

open and read with the Java-based viewer JAtlasViewer. Through this viewer, the user can relate 3D structure and histological135

cross-sections at any cutting plane defined in the application. At the cost of losing the possibility to view cross-section136

histology (which would however still be available on the EMAP website), Blender provides an alternative way of manipulating137

and exploring 3D objects, while also allowing easy customisation of the models, rendering to 2.5D illustrations, the creation of138

scenes with multiple models, sculpting, and more advanced functionalities. Furthermore, and for 3D models that do not benefit139

from curated interactive visualisation platforms such as those of EMAP, Blender simply provides an easy-to use interaction140

and exploration platform.141

142

To explore the embryonic models provided, just download the corresponding .blend file. If Blender has been installed on the143

computer, the file should then be openable just by double-clicking on it (Figure 6.1, here TS13 as an example). One can now144

freely explore the embryo. Unwanted tissues and structures (e.g. outer layers hiding internal structures) can be toggled off by145

clicking on the eye icon next to their name in the lateral menu (Figure 6.2). If one is unsure of the name of the tissue to be146

removed, right clicking on it will highlight its name in orange in the lateral list (later stage models are made up of up to 80147

components!). As a rule of thumb, one will likely want to toggle off all extraembryonic tissues: these can be easily identified148

because their name is preceded by an "X" (see Supplementary Data Table). In the example provided here, most extraembryonic149

tissues have been removed, as well as mesenchmyal and cardiovascular structures around the tailbud to get a better view of gut150

tube and notochord.151

152

Exploration of the model can then proceed by scrolling in/out with the centerwheel of the mouse (zoom in/out), moving the153

mouse while holding the wheel down (rotation around the model), and moving the mouse while holding SHIFT and the wheel154

down (panning vertically and horizontally). Alternatively, and from Blender 2.8 onward, one can more simply interact with155

either of the three icons on the top right of the viewer (see Figure 6.3). In the example, this has been done to get a better view156

of how the endoderm pockets into the anterior of the embryo (left), and to track the notochord as it emerges from the tailbud157

(right).158

Fig. 6. Exploring 3D embryonic models in Blender: moving perspective.

159

An alternative way to explore the embryo models provided is to move and rotate the model itself, and to move structures in and160

out of them (see Figure 7, TS09 as an example). To move the whole embryo at once, select the "HANDLE" object in the list161

on the right (left-click on the name, Figure 7, bottom). The model can be now moved along the three axes, or rotated around162

them, by clicking on the corresponding icons at the left of the screen and then interacting with the widgets that appear on top163

of the model (Figure 7.2, move icon; Figure 7.3, rotate icon). The same actions can be performed with the keyboard shortcuts164

G (for "grab", followed by X, Y, or Z to lock the movement along these axes), and R (for "rotate", followed by X, Y, or Z to165

lock the rotation around these axes). The same can be done on individual components, rather than on the whole embryo, by166

selecting them first (right click on them in the viewer, or left click on their name on the right panel). In Figure 7.4 this has been167

done on the (visceral) endoderm to move it down and reveal the epiblast and the primitive streak at one side of the embryo168

(some extraembryonic structures were also toggled off as explained before).169

170

171
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Fig. 7. Exploring 3D embryonic models in Blender: moving the model

Thus, the simple use of basic Blender functions (movement in space, on/off visibility toggling, object interaction and172

manipulation) allows for unbounded exploration of any of the embryonic models provided, allowing users to easily visualise173

and understand the spatial relationship of their structure of interest in the context of the whole embryo. In fact, it would174

be interesting to explore whether such exploration could improve visual-spatial literacy in the users, and whether this could175

represent a valid and beneficial tool within developmental biology pedagogical settings. To quote Hardin (2008): "the176

technology already exists to depict embryos on the computer as true 3D objects in 4D space. What is needed is the application177

of instructional materials development resources toward the production of such models. If such models become widely178

available, it should be possible to reclaim all four dimensions of the embryo in the undergraduate developmental biology179

curriculum ".180

181

While these models have been here made available as pre-prepared .blend file, one can exploit these same basic functions to182

explore any type of volume data (.obj, .wrl, .stl; imported in a Blender scene via File>Import). This has been e.g. recently183

exploited for 3D exploration of cell migration tracking data in Samal et al. (2020), and can also be applied to explore .obj/.stl184

meshes generated from e.g. light-sheet imaging.185
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Use of the models for illustration.186

187

The second advantage allowed by having access to 3D models in Blender is the possibility to create 2D (2.5D) illustrations188

out of them. This is done by taking snapshots of them at the angle needed: this creates an output image, a process called189

rendering (see Glossary), where the illustration software applies materials to the models (colour, roughness, refractivity...) and190

light to the scene. Regardless of drawing or artistic skills, one can thus generate reference figures for publications, scientific191

illustrations, material for outreach purposes, or even art. The illustration process thus becomes focused on the concept and192

message one wants to illustrate rather than on the technical aspects of it: accurate embryo models are already provided.193

Furthermore, illustrations of embryos from non-traditional perspectives do not require to mentally recalculate what the embryo194

would look like (think about how few illustrations show mouse embryos from the ventral or anterior side, compared to the195

lateral or dorsal sides).196

197

To explain how the models provided here can be used for illustration, we will take a simple case study: that of a scientist198

wanting to illustrate endoderm development after gastrulation. This process involves extensive shape changes as the endoderm199

starts as a curved sheet on the surface of the embryo, later makes deep pockets at its two extremities, and finally closes to form200

a tube (the gut) while the whole embryo is closing on itself (Lewis & Tam, 2006). Illustration is made especially challenging in201

our case because the scientist is not confident they fully understand how the terminal endoderm pockets fit with other structures202

at the anterior and posterior of the embryo.203

204

To create an illustration, one first need to set up a scene. In our specific case, the single-stage .blend files available for download205

are not sufficient: we would like to show models TS09 to TS14 within the same image. We will thus open TS09, and import206

the other models from the other files by selecting File>Append (Figure 8.1), navigating to the .blend file with the model needed207

(here TS10), opening its Collections folder, and selecting the TS10 entry. Appended models will be imported within the existing208

hierarchy, so make sure that you are in the topmost collection (Scene Collection, see Figure 8.1) before importing any model.209

Once the model has been imported and positioned (Figure 8.2; see previous section for how to move models in Blender),210

one can repeat the Append process to add each of the following embryonic stages (Figure 8.3). As explained before, specific211

structures and layers can be then toggled off (eye icon) to expose the structures one is interested in (here, the endoderm) (Figure212

8.4).213
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Fig. 8. Importing models from other files by using File>Append>Collection
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Once the scene is set with all the models in the right place, it is time to add shaders/materials. Materials determine the final214

appearance (in its simplest form, the colour) of the models in the output illustration, and as such have a heavy influence on its215

success. To get an idea of what the final image will look like one can toggle the Rendered Viewport Shading icon at the top216

right of the viewport (Figure 9.2; allow some processing time). Since all models provided here come with a generic grayish217

shader, this is indeed how the models will look like (Figure 9.2). An important note is that, depending on where you placed218

your models into the scene, there might nor be enough light to actually see the real final colour of the model. This case is219

shown in Figure 9.3B, and corrected in Figure 9.3C by providing more light to the rightmost model. In Blender, light is220

extremely important, and every .blend model provided here comes with it’s own set of lamps. These are the objects highlighted221

in orange in Figure 9.3A, and can be imagined as literal rectangles shining light out of their surface: one illuminates the front222

of the model and the other the top. To add lights, select both of them (if using the name list on the right, Shift+LeftClick;223

if clicking directly on the objects, Shift+RightClick), press Shift+D to duplicate, and then move them to your next model (in224

Figure 9.2 you can indeed see how additional lights have been placed all along the lineup of models).225

226

Fig. 9. Rendered viewport and lights
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It’s then now time to apply materials to the structures we want to highlight (endoderm in this case). For a 2D illustration227

analogy, this is equivalent to having drawn a shape on paper and now having to colour it in. While Blender allows the228

creation of virtually any material one can imagine, we facilitated the task here by providing a starter-pack of pre-made ones229

("materials.blend", see Figure 5) alongside the embryo models. To import any of these materials into the scene, repeat the230

same process used to import additional embryo models (File>Append) but this time select the "materials.blend" file, and pick231

from the "Materials" folder. In this scene we will start by using the "cells_yellow" material. Once it has been imported, apply232

it by selecting the component you want to colour (here the visceral endoderm, Figure 10.1), clicking on the red checkered233

sphere icon in the panel on the right (this is the materials icon), and use the drop-down menu to select the material you just234

imported (Figure 11.1, right). Provided you are still in Rendered View mode (toggled on previously), the model will now look235

as in Figure 10.2. Proceed for all other models (materials only needed to be appended once) until satisfied (Figure 10.3). Since236

the endoderm soon starts being populated by cells intercalating from the mesoderm (Viotti et al., 2014), we have switched to237

the "cells_intercalating" material for all later models to better illustrate this phenomenon.238

239

Fig. 10. Applying materials

The models are in place, the scene is illuminated, and materials have been applied. We are now ready to transform this 3D240

scene into a 2D image. This is done by taking a virtual snapshot of our models, a process called rendering. This "snapshot"241

is taken with a Camera, which is indeed provided with all Blender scenes, just as lamps and lights are. To place the camera242

in position, start by positioning your view as to see your models as you want them in the final image (Figure 11.1). With the243

camera object selected (left-click on its name in the panel on the right), click on View>Align View>Align Active Camera to244

View (Figure 11.2): this will move the camera in position, and make you look through it. If all your models disappear at this245

point, this is because they happen to be out of the working distance range of the camera. To correct this, and with the camera246

object still selected, click on the green camera tab in the bottom right panel, and increase the End value until the models appear247

again (Figure 11.3, 10000 meters in this case). As in Figure 11.4A, the camera will not exactly capture the whole scene and248

will likely need to be moved "in" or "out" as to capture a smaller/bigger area. This is done by moving the camera along its249

relative Z axis, which is set through the keyboard shortcut "G" (for "grab"), followed by "Z" (lock movement to absolute Z250

axis), followed by "Z" again (lock movement to relative Z axis). Adjust the camera position until satisfied (Figure 11.4B):251

what you see through the camera is the snapshot that will be taken.252

253

Once the camera is in place, it is time to launch the rendering process. To avoid any surprises, start by making sure that all254

the objects that had been hidden from view (eye icon toggled off), are also hidden from the final render. Just as you toggled255

off the eye icon next to the name of each object, toggle off the camera icon too (Figure 11.5A; if this icon is not shown, make256

it available from the Filters submenu as shown). Another aspect to double-check is that the "Transparent" Film checkbox is257

ticked in the display settings in the bottom left panel (tab with the camera icon, Figure 11.5B) because this will make the258
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background transparent when the image is then saved as .png. Finally, the size/resolution of the final image can be set in the259

rendering tab (Figure 11.5C, tab with printer icon, here 1920px x 1080px). Notice that if you change the ratio of these values,260

your camera will also resize and you will need to realign it. Once all is set, launch the rendering via Render>Render Image261

(Figure 11.5C, bottom). A new window will open, and after some processing time, the final image will appear (Figure 11.6C).262

Save the image via Image>Save As. The image is done (Figure 11.7).263

264

Fig. 11. Camera positioning and rendering.
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Illustrating cross-sections.265

266

As a final illustration technique, a developmental biologist might often need to show cross-sections or cut-outs of a specific267

tissue: that is, not toggle the tissue off view completely, but just remove a section of it as to show underlying structures. This268

is achieved in Blender through the use of so-called Boolean modifiers, which essentially allow to substract/add shapes from/to269

one another. A cube or a parallelepiped can thus be intersected with our tissue of interest and the intersection deleted out.270

Upon removal of the cube, the tissue is left open: a process illustrated in Figure 12.271

272

As a first step, one needs to create the shape to be subtracted. Making sure that one is in the topmost hierarchy (Scene273

Collection), add a cube to the scene by selecting Add>Mesh>Cube (keyboard shortcut Shift+A) (Figure 12.1). To scale the274

cube right-click on it (Figure 12.2) and select the Scale icon on the left, or use keyboard shortcut "S", followed by X, Y, or275

Z to lock the scaling to either of the three axes. Since we here want to cut out the visceral endoderm both in the embryonic276

and in the extraembryonic region, we make a parallelepiped that is as tall as the embryo (Figure 12.3). Once satisfied with the277

shape, move it as to intersect your model over the regions you want to carve out (Figure 12.4), select the tissue that needs to278

be cut (here starting with the embryonic visceral endoderm), and select the wrench icon of the bottom right menu (modifiers279

tab, Figure 12.5). Under "Add Modifier", select "Boolean", and then make sure that the Operation is set to "Difference", and280

the Object field displays the shape you want to subtract (our parallelepiped is called "Cube" in this example; Figure 12.5).281

Click on "Apply" and then repeat the whole process for the extraembryonic visceral endoderm. Once both tissues have been282

processed, delete the parallelepiped by pressing the keyboard shortcut "X" (Figure 12.6) to reveal what is left of the model (Fig-283

ure 12.7). We can now clearly see epiblast and primitive streak under this newly created window through the visceral endoderm.284

285

Because the models provided here are not "solid" (they are actually hollow, thin-layered envelopes), the kind of editing de-286

scribed above might reveal exposed holes in the cross-sections (Figure 12.8A, the cut visceral endoderm is hollow). These are287

problematic because one wants to hide this in the final illustration and give the impression of a solid model. To correct this,288

switch to Edit Mode (keyboard shortcut "Tab", or as in Figure 12.8A, right) to enable interaction with the mesh of the objects289

(Figure 12.8B). After deselecting everything (keyboard shortcut Ctrl+A), toggle the edge-selection icon, and select any edge of290

the mesh making up the border of the exposed side (Figure 12.8C). Now use Select>Select Loops>Edge Loops to automatically291

select the entire border (Figure 12.8D), and press keyboard shortcut "F" to create a new face within the perimeter defined by292

this border (Figure 12.8E). By leaving Edit Mode and going back to Object Mode (keyboard shortcut "Tab") one can see that293

this gives the illusion of a solid model (Figure 12.8F), which can now be processed for illustration as described above.294
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Fig. 12. Creating cut-outs and using Edit Mode
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Non-conventional uses and outreach295

Crucially to the paradigm outlined in Figure 3, and even though the status-quo (bias) of academia might suggest otherwise,296

scientific communication does not take its only form as that of a published image in a journal, nor does creative experimentation297

have to falter in the constraints of the printed page. As such, while 3D models do allow the generation of conventional 2D298

figures as described above, they also uniquely open up the doors to a wide variety of new forms of user data-engagement299

which are unthinkable if only dealing with pen and paper. Notably, non-conventional communication media and illustrations300

tools such as Augmented Reality, Virtual Reality, and 3D printing (see Glossary, and Figure 13), all require at their source the301

availability of 3D models of the objects to be brought to life (usually in either .obj or .stl format). Up to now, and in the absence302

of readily available compatible models, the use of these technologies to communicate mouse embryology thus required the303

sculpting of each of these models from scratch in software like Blender, or the generation of appropriate microscopy volume304

data in the lab. These requirements are unrealistic for many, either in terms of skills or opportunity, and especially since305

communicators and data generators might not always be the same person. Indeed examples where such approaches have been306

deployed are few. Yet because of their novelty, and because they engage different senses in addition than just sight, these307

communication strategies hold extraordinary didactic potential, whether within academia or for outreach.308

309

The goal of this section is not to provide a detailed guide on how to deploy embryo models in virtual reality, augmented310

reality, or 3D printing, but just to highlight that this is possible with free and open source software. Hopefully, the em-311

bryonic models provided here can at least jump start experimentation in these avenues by interested parties. Examples312

of potential applications include the projection of rotating models out of posters/papers to allow live user exploration of313

the specific embryonic stages discussed (Figure 13.1), deployment of mouse embryos in virtual reality environments as to314

captivate unfamiliar but interested audiences for outreach (Figure 13.2), and multimaterial 3D printing of replica models for315

didactic purposes (Figure 13.3; bones in this example from https://vizbi.org/Posters/2019/B02). While a variety of different316

solution exist for each of these applications, augmented reality apps can be built for example with a combination of Unity317

and Vuforia, or the web-based AR.js. A basic script and setup behind the AR triggered by Figure 13.1 is provided at:318

https://github.com/StefanoVianello/Augmented_Reality. Virtual reality scenes can similarly be created by importing models319

in Unity and coupling this to a e.g. Google Cardboard interface; and 3D printers only require the user to supply one of the320

models available here. 3D printers are increasingly common in universities or in so-called community makerspaces, and we321

recommend considering printers with a dual nozzle setup to allow multimaterial fabrication.322

323

Fig. 13. Non-conventional uses of 3D models for communication 1. Augmented Reality to bring to life posters and papers. 2. Example of Virtual Reality setup (Unity
software) 3. 3D printed models from Inoue, Leevy 2019 (https://vizbi.org/Posters/2019/B02)
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Conclusion324

By converting EMAP models to a more versatile format, and by sharing them alongside models of earlier embryonic stages as325

ready-to-use .blend files, I hope to instill new life in such an important resource and to make its models even more accessible326

to the community. Undoubtedly, many researchers in the field of mouse developmental biology are in possession of 3Dmodels327

of various structures and embryonic stages, or generate these models as part of their research. I hope this guide can serve as328

a soft introduction to software (such as Blender) that allows exploration and use of these models for illustration, software that329

is otherwise associated with a steep learning curve and might appear overwhelming in its variety of functionalities. Hopefully,330

the considerations made here will also serve as an encouragement to authors to make future 3D models models they might331

generate as accessible as possible to the public, as their value transcend that of publication. For scientists, creators, communi-332

cators, teachers, and artists reading this, I hope these models can act as fertile substrate for creative exploration, and ultimately333

encourage new paradigms through which to live, communicate, and teach Developmental Biology.334

Methods335

Data availability. All data has been deposited on Zenodo (http://doi.org/10.5281/zenodo.4284380). These include: i) indi-336

vidual .stl models of embryonic subcomponents for each developmental stage (e.g. epiblast, visceral endoderm; 1 folder per337

embryonic stage); ii) ready-made .blend files where such components have been reassembled as a full embryo model, and in338

a scene with pre-prepared light sources and aligned camera (1 file per embryonic stage); iii) a .blend file with all embryonic339

models provided arranged in a temporal lineup; iv) a .blend file with a "starter-pack" of pre-made materials to use for easy340

illustration.341

Processing of EMAP models. EMAP models of each Theiler Stage (TS07 to TS14) were downloaded from the EMAP342

website (https://www.emouseatlas.org/emap/ema/home.php; also available at https://datashare.is.ed.ac.uk/handle/10283/2805 )343

as individual .zip files. These files contain .vtk and .wlz models of i) the entire embryo and of ii) each individual embryonic344

subcomponent. Each folder was then decompressed (extracted), .wlz files were removed, and .vtk files were renamed according345

to the key provided in Supplementary Data Table. These files were then converted into .stl files through the script provided346

at https://doi.org/10.5281/zenodo.4284367 (Note, an alternative conversion script is also available at https://github.com/ma-347

tech/PyWoolzScripts/blob/master/WlzDomainToVTKSurf.py, from Bill Hill, EMAP team). The resulting objects were finally348

imported into Blender 2.80, and reassembled to form a combined model of the entire conceptus for each Theiler Stage. Models349

corresponding to Theiler stages 01 to 06 are not available from the EMAP website and were custom made in Blender. See350

dedicated Methods section for more details on how these were made.351

Blender assembly of full embryo models. For each Theiler stage (TS07 to TS14), individual .stl components were imported352

into Blender 2.80 (File>Import>stl), shaded smooth (Object>Shade Smooth), scaled (scale: TS12 TS14 0.2. TS07-11 0.09).353

Origins were set to the centre of mass of each volume (Object>Set Origin>Origin to centre of mass (volume)), and an "empty"354

was created (Add > New > Empty) and parented to all imported pieces (control+P > Parent to Object). The whole conceptus was355

then assigned to a dedicated collection (group of objects, Object>Collection>Move to collection > New Collection ), moved356

to [0,0,0], and rotated 180° with respect to its y-axis as to align the top of the model to the positive z-axis. Models were then357

rotated with respect to their z axis to align their posterior to the positive y axis (right side of the viewer). Finally, models were358

all assigned the material "base_material_white", Color Management was kept as default (Filmic), Exposure 3, Gamma 0.75.359

"Film" was set as "Transparent" so that renders are created as .png by default. Note about scale: all models provided inherited360

size parameters from the files downloaded from EMAP. This means that TS07 to TS11 are all in scale with respect to each other361

and proportional to each other because they were all here rescaled by the same factor. Other models are provided unscaled and362

may need manual adjustment based on user needs (realism vs illustrative needs).363

Material preparation. A set of pre-made materials is available for download as to avoid having to create them from scratch.364

Base and Neutral materials (see Figure 5) were constructed from a single "Principled BSDF" node set on the appropriate base365

color (e.g. lightblue for the "neutral_lightblue" material), all other settings left to default (GGX, Christensen-Burley, Subsur-366

face: 0, Subsurface Radius: 1-0.2-0.1, Subsurface Color: E7E7E7, Metallic: 0, Specular: 0.5, Specular Tint: 0, Roughness:367

0.5, Anisotropic: 0, Anisotropic Rotation: 0, Sheen: 0, Sheen Tint: 0.5, Clearcoat: 0, Clearcoat Roughness: 0.3, IOR: 1.450,368

Transmission: 0, Transmission Roughness: 0, Emission: 000000, Alpha: 1). Glossy materials will give a wet-like appearance369

to the model, and were made just as Neutral materials but with Roughness: 0, and Clearcoat: 1. The "cells_yellow" mate-370

rial was created by mixing ("Mix Shader") two "Principled BSDF" nodes with the default settings listed above for Base and371

Neutral Materials, with two different shades of yellow as Base Color. The "Normal" imput of the node with the lighter shade372

was plugged to a "Bump" node (Invert: unchecked, Strength: 1, Distance: 1) whose "Height" input was linked to the "Color"373

output of a "Voronoi Texture" node (Cells, Distance, Closest, Scale: 9.6). The "Fac" output of this same node was linked to a374

"ColorRamp" node, whose "Color" output was linked to the "Fac" input of the Mix Shader mixing the two original Principled375

BSDF nodes. The "cells_intercalating" material was created with the same basic setup as "cells_yellow", but a "Musgrave376
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Texture" node was used instead of a "Voronoi Texture" (fBM, Scale: 18.2, Detail: 4.6, Dimension: 1.614, Lacunarity: 10.5,377

Offse: 0.5, Gain: 0). Altering the Scale value of this node will allow to change the size of the cells as a function of the size of378

the tissue of interest. The "Bump" node had values= Invert: unchecked, Strength: 1, Distance: 0.2. The "transparent" material379

was created by mixing ("Mix Shader") a "Principled BSDF" node set as for Base and Neutral Materials (Base Color: FFFFFF)380

and a "Transparent BSDF" node (Color: FFFFFF). The "Fac" value of the Mix Shader was set at 0.225 (for the transparent381

input).382

Preparation of pre-implantation models. Models for the 1-, 2-, and 4-cell stages (TS01.blend, TS02-2cell.blend, TS02-383

4cell.blend) were created from simple sphere shapes (Add>Mesh>UV Sphere). Models for the 8-cell stage, morula, early384

blastocyst, late blastocyst, and implanting blastocyst stages (TS03-8cell.blend, TS03-16cell.blend, TS04.blend, TS05.blend,385

TS06.blend) were created by using the Particle Emitter function in Blender. Briefly, an object of the desired shape (a sphere386

for most models; a sculpted "implanting" mesh for TS06.blend) is added (Add>Mesh>UV Sphere) and selected as an "emitter"387

object ("Particles" properties tab). Another object (the 1-cell model) is imported (File>Append) and selected as the "emitted"388

object. If the particle settings of the emitter object is set as "Hair", running the simulation (keyboard shortcut: spacebar) will389

lead to individual cells emerging out of (and thus covering) the faces of the object. The entire system was then saved as a single390

model by applying the particle modifier ("Convert") of the emitter object. The entire setup used to create each of the models is391

included in the .blend files provided, for reference and hidden from view in a dedicated collection called "Emitter_system".392

The open versions of the early and mid-blastocyst models (TS04_HALF.blend, TS05_HALF.blend) were generated as above,393

but the emitter object used was a hollowed out hemisphere for the surface that will be covered by trophectoderm cells, and a394

separate shape for the surface that will be covered by inner cell mass cells (TS04_HALF.blend). For the latter particle system,395

the "emitted" object was a collection of two different cell objects: a sphere to represent epiblast cells, and another sphere to396

represent primitive endoderm cells. To instead avoiding having intermingled cells in TS05.blend, two separate inner emitters397

were used (each producing one type of cell).398
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